Email deliverability issues
Incident Report for Rodeo
Resolved
This incident has been resolved.
Posted Feb 16, 2023 - 12:58 CET
Update
Outbound emailing resumed normal operation, and deliverability problems are close to non-existent. Please reach out to our Support team, if for some reason you are still experiencing issues related to emails sent through our platform.
Posted Feb 16, 2023 - 12:57 CET
Monitoring
Some users are experiencing email deliverability issues potentially affecting emails sent through Rodeo's web application. Our team is working to resolve it urgently.

If you are about to send an invoice to a customer, please consider downloading it as a PDF and sending it from your email account until this issue is resolved.
Posted Nov 30, 2022 - 20:21 CET
This incident affected: Rodeo Classic - Integrations (E-mail).