Service unavailable
Incident Report for Rodeo
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 16:02 CEST
Investigating
We are currently investigating this issue.
Posted Apr 25, 2024 - 12:30 CEST
This incident affected: Rodeo Classic - Web Application (Login and Dashboard, Invoices and Estimates, Time Tracking, Expenses, Planning and Tasks, Project and Budget, Reporting), Rodeo Classic - Integrations (Exact Online, Quickbooks, E-mail), Rodeo Drive - Integrations (Exact, e-boekhouden, yuki, basecone, snelstart (NL), Xero (UK), Quickbooks (US)), Rodeo Drive - Web Application (Login, Invoices, Directory, Estimates, Project budgets, Planner, Payable (Purchase Orders / Purchase Invoices), Time Tracking), and Website.