Issue when viewing invoices
Incident Report for Rodeo
Resolved
This incident has been resolved.
Posted May 22, 2023 - 12:54 CEST
Investigating
Currently we are experiencing issues with the invoicing module. Invoices can be created and send, but are not visible in the invoice view.

This issue is impacting all customers, and is being actively investigated, but unfortunately couldn't be resolved yet. An update will be given as soon as possible.
Posted May 18, 2023 - 03:45 CEST
This incident affected: Rodeo Classic - Web Application (Invoices and Estimates).